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BeyondTrust Integration with BMC Remedy

IMPORTANT! 

You must purchase this integration separately for both your Remote Support software and your BMC Remedy solution. For more 
information, contact BeyondTrust's Sales team.

Service desks and customer support organizations using BMC Remedy can integrate with BeyondTrust to improve service levels, 
centralize support processes, and strengthen compliance. This document describes the installation and configuration of the BeyondTrust 
Remote Support integration with BMC Remedy.

The BMC Remedy integration with BeyondTrust Remote Support provides the following functionality:

 l A BeyondTrust support session can be initiated from the context of a BMC Remedy ticket.
 l A BeyondTrust Jump session can be initiated to a computer system Configuration Item associated with a ticket.
 l At the end of a session, the incident can be updated with the session information.

SALES: www.beyondtrust.com/contact SUPPORT: www.beyondtrust.com/support DOCUMENTATION: www.beyondtrust.com/docs 4
©2003-2024 BeyondTrust Corporation. All Rights Reserved. Other trademarks identified on this page are owned by their respective owners. BeyondTrust is not a chartered bank or trust company, or
depository institution. It is not authorized to accept deposits or trust accounts and is not licensed or regulated by any state or federal banking authority.

TC: 3/4/2024

REMOTE SUPPORT

BMC REMEDY INTEGRATION



Prerequisites for the BeyondTrust Remote Support Integration 
with BMC Remedy
To complete this integration, please ensure that you have the necessary software installed and configured as indicated in this guide, 
accounting for any network considerations.

Applicable Versions
 l BeyondTrust Remote Support: 14.x and newer
 l BMC Remedy:  8.x and newer

Network Considerations
The following network communication channels must be open for the integration to work properly.

Outbound From Inbound To TCP Port # Purpose

BeyondTrust 
Middleware Engine 
Server

BMC Remedy 443 API calls from the BeyondTrust Middleware Engine 
server.

BeyondTrust 
Middleware Engine 
Server

BeyondTrust Appliance 
B Series 443 API calls from the BeyondTrust Middleware Engine 

server.

BeyondTrust Appliance 
B Series

BeyondTrust 
Middleware Engine 
Server

8180 (default)

443 (optional)

The BeyondTrust Middleware Engine server 
receives outbound events from the B Series 
Appliance. However, if polling is used instead of 
outbound events, then this port does not have to be 
open.

Prerequisite Installation and Configuration
The BMC Remedy integration is a BeyondTrust Middleware Engine plugin.

For more information on installing and working with the BeyondTrust Middleware Engine, please see the BeyondTrust Remote 
Support Middleware Engine Installation and Configuration document at www.beyondtrust.com/docs/remote-support/how-
to/integrations/middleware-engine.
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Configure BMC Remedy for Integration with BeyondTrust 
Remote Support
Integration between BMC Remedy and BeyondTrust Remote Support requires importing a collection of custom objects into the BMC 
Remedy environment. These include Filters, Active Links, Web Services, etc. The following steps outline this import and configuration 
process.

Initially, some manual steps must be taken before the bulk of the AR System items can be imported.

Import Forms

 1. Open BMC Remedy Developer Studio.
 2. From the main menu, select File > Import.
 3. Expand BMC Remedy Developer Studio.
 4. Select Object Definitions and click Next.
 5. Select the appropriate server and click Next.
 6. Select the bomgar_Remedy_Int_With_Incident_Vx.x.xml file from the appropriate location and click Next.
 7. From the XML file, add the following forms, removing all other items:

             

 l COL:BGR:SessionDetail:Staging
 l COL:BGR:Configuration:Params
 l COL:BGR:Form:Setup_Template

 8. Select the following options:             

 l Replace Objects on the Destination Server
 l Delete Excess Views
 l Replace Application Owner
 l Handle Conflicting Types: Display Conflict Error

 9. Click Finish.

Note: The import process may take several minutes to complete. 
Upon successful completion, the above forms will have been 
imported into the AR System.
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Update Existing Forms - HPD:Help Desk

Note: Before this operation, determine in which views the fields will be visible.    

To save time, it may be a good idea to set the Remedy 
Administrator preferences (in the Windows > Preferences menu) 
so that fields are not automatically added to all views. This way, 
fields are added only to the views to which they are pasted. Also, 
make sure to back up the Incident Form.

 

 1. Open the Incident form (HPD:Help Desk) in the Best Practices view in Developer Studio.
 2. Also open the newly imported COL:BGR:Form:Setup_Template.
 3. If the Incident form does not already have an overlay, select Forms > Create View Overlay from the menu.
 4. Add a new Panel with the following properties:             

 l ID: 800000001
 l Name: COL_Pnl_BeyondTrust_Sessions
 l Label:BeyondTrust Sessions
 l Vislble: False
 l Permission: Public

 5. Copy and paste the following fields from the Setup_Template form to the new panel on the Incident form.             

 l 800000002: COL_Tbl_Session_Summary
 l 800000003: COL_Col_Session_ID
 l 800000004: COL_Col_Start_Time
 l 800000005: COL_Col_End_Time
 l 800000006: COL_Col_Duration
 l 800000007: COL_Col_File_Count
 l 800000008: COL_Col_Representative
 l 800000009: COL_Ctrl_BeyondTrust_Logo
 l 800000010: COL_Char_Support_Session_Details
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 6. Once complete, the BeyondTrust Sessions panel should look 
similar to the screen shot. Save the form.

Add "Launch BeyondTrust Session Key" Link to Left Navigation

 1. Add the left navigation z2NF_LeftNavigation to the overlay and save it.
 2. Select the left navigation from the outline window and right-click it.
 3. Select Edit Menu / Navigation Items.
 4. In the Edit window, expand the Functions items to add a new item 

under this menu.
 5. Select the Functions menu and click Add Item.
 6. Once the item is added, select it and edit its properties to match the 

following:             

 l ID: 900370918
 l Name: COL_z2NI_LaunchBomgarSession()
 l Label: Launch BeyondTrust Session Key
 l Visible: True
 l Permission: Public

 7. Save the Incident form.

Add Display-Only Fields

 1. Copy the following display-only fields from the Setup_Template 
form to the bottom area of the Incident form:             

 l 900070914: z2tmp_LaunchURL
 l 900070917: z2tmp_Launch_CI
 l 900270919: z2tmp_SessionURL

 2. Save the form.
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Add "Launch BeyondTrust Jump Client" Link to Left Navigation

 1. Select the left navigation from the outline window and right-click it.
 2. Select Edit Menu / Navigation Items.
 3. In the Edit window, expand the Functions items to add a new item under this menu.
 4. Select the Functions menu and click Add Item.
 5. Once the item is added, select it and edit its properties to match the following:             

 l ID: 908970913
 l Name: COL_z2NI_Launch BeyondTrust CI
 l Label: Launch BeyondTrust Jump Client
 l Visible: True
 l Permission: Public

 6. Save the Incident form.

Update Existing Forms - SRS:RequestDetail

 1. Open the Service Request Console form (SRS:RequestDetail) in SRS User view in Developer Studio.
 2. Also open the newly imported COL:BGR:Form:Setup_Template (SRM-RQC View).
 3. If the Service Request form does not already have an overlay, select Forms > Create View Overlay from the menu.
 4. Copy and paste the following fields from the Setup_Template form to the new panel on the Service Request form.             

 l 800000600: COL_Btn_Get_Support_Now
 l 800000601: COL_VF_Launch_Support_Window
 l 800000602: COL_Char_Mid-Tier_URL
 l 800000603: COL_Char_Incident_Number

 5. Once complete, the request details should look similar to the screen 
shot. Save the form.
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Import Remaining Items
Once the manual steps above have been completed, the remainder of the package can be imported.

 1. From the main menu, select File > Import.
 2. Expand BMC Remedy Developer Studio.
 3. Select Object Definitions and click Next.
 4. Select the appropriate server and click Next.
 5. Select the bomgar_Remedy_Int_With_Incident_Vx.x.xml file from the appropriate location and click Next.
 6. Import all objects, making sure to select Replace Objects on the Destination Server.
 7. Click Finish.

Note: The import process may take several minutes to complete. Upon successful completion, the required forms, 
workflows, and web services will have been imported into the AR System.

 8. Flush the Mid-Tier and browser caches, located at <protocol>://<mid-tier-server>:<port>/arsys/shared/config/config.jsp.

Configure the Integration

 1. In a browser, open the Configuration Params form 
(<protocol>://<mid-tier-server>:<port>/arsys/forms/<AR-
server-name>/COL:BGR:Configuration:Params).

 2. Add attribute details for the BeyondTrust Server attribute for both 
the Launch Session and Launch BeyondTrust CI (Jump Client) 
items.

 3. The Attribute Value should be https://<BeyondTrust-site-
hostname>.

 

Note: Access to the BeyondTrust Sessions tab as well as the Session Key and Jump to CI functions are controlled by 
users' group memberships.  Any user who should have access to these items should be added to a new Group in Remedy 
named "BeyondTrust Users".
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Configure Smart IT for the Integration between BMC Remedy 
and BeyondTrust Remote Support
If your environment has Smart IT available, there are a few use cases that can be implemented within Smart IT.

Generate BeyondTrust Session Key

 1. Log in to Smart IT as an admin user (<protocol>://<mid-tier-
server>:<port>/ux/smart-it/#/).

 2. Navigate to Configuration > Screen Configuration.

 

 3. In the Incident View section, select Add/Remove Actions.

 

 4. Create a new action with the following settings:             

 l Action Type: Client-side URL
 l Supported Platforms: Desktop Web (UC)
 l URL/URI:https://<BeyondTrust-

hostname>/api/client_script?public_portal_
hostname=<BeyondTrust-public-portal-
hostname>&type=rep&
operation=generate&action=generate_session_
key&session.custom.external_key=[id]

 l Open Behavior: New Browser Window
 l Default Label Text: Generate BeyondTrust Session Key

 5. Save the action.
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Leverage Smart Recorder to Create Incidents

BeyondTrust 15.1 and later

 1. Log in to the BeyondTrust /login interface as an admin user.
 2. Browse to Rep Console > Custom Links.
 3. Under Rep Console :: Custom Links, click Create New Custom Link.
 4. Create a link with the following settings:             

 l Name: Create Incident via BMC Smart IT
 l URL:<protocol>://<mid-tier-server>:<port>/ux/smart-it/#/create/smart-

recorder?customer=%CUSTOMER.NAME%&desc=%SESSION.DETAILS%

 5. Click Add Custom Link to save the new link.

BeyondTrust 15.0 and earlier

 1. Log in to the BeyondTrust /login interface as an admin user.
 2. Browse to Configuration > Options > Representative Console :: Custom Link.
 3. Set the URL to <protocol>://<mid-tier-server>:<port>/ux/smart-it/#/create/smart-

recorder?customer=%CUSTOMER.NAME%&desc=%SESSION.DETAILS%

 4. Click Save.
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Configure BeyondTrust for the BMC Remedy Integration
Several configuration changes are necessary on the B Series Appliance to integrate with BMC Remedy. You must make these changes 
on each B Series Appliance for which you intend to create a plugin configuration, described in "Configure the BMC Remedy Plugin for 
Integration with BeyondTrust Remote Support" on page 16.

All of the steps in this section take place in the BeyondTrust /login administrative interface. Access your Remote Support interface by 
going to the hostname of your B Series Appliance followed by /login (e.g., https://support.example.com/login).

Verify the API Is Enabled

Management API CONFIGURATION

This integration requires the BeyondTrust XML API to be enabled. This 
feature is used by the BeyondTrust Middleware Engine to communicate 
with the BeyondTrust APIs.

Go to /login > Management > API Configuration and verify that Enable 
XML API is checked.
 

Create an OAuth API Account

Management API CONFIGURATION

The BMC Remedy API account is used from within BMC Remedy to make Remote Support Command API calls to Remote Support.

 1. In /login, navigate to Management > API Configuration.
 2. Click Add.
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 3. Check Enabled.
 4. Enter a name for the account.
 5. OAuth Client ID and OAuth Client Secret is used during the 

OAuth configuration step in BMC Remedy.
 6. Under Permissions, check the following:             

 l Command API: Full Access.
 l Reporting API: Allow Access to Support Session 

Reports and Recordings, and Allow Access to 
Presentation Session Reports and Recordings.

 7. Click Save at the top of the page to create the account.

 

Add an Outbound Event URL

Management OUTBOUND EVENTS

 1. Go to /login > Management > Outbound Events.
 2. In the HTTP Recipients section, click Add and name it Integration 

or something similar.
 3. Enter the URL to use:

 l If using an appliance ID of default: http://<middleware-
host>:<port>/
ERSPost. The default port is 8180.

 l If using an appliance ID other than default: 
http://<middleware-host>:<port>/
ERSPost?appliance=<appliance-id> where 
<middleware-host> is the hostname where the 
BeyondTrust Middleware Engine is installed. The default 
port is 8180. The <appliance-id> is an arbitrary name, but 
note the value used, as it is entered later in the plugin configuration. This name accepts only alphanumeric values, periods, 
and underscores.

 4. Scroll to Events to Send and check the following events:

 l Support Session End
 l Customer Exit Survey is Completed
 l Representative Survey is Completed
 l Someone Joins a Support Session (Optional)

 5. Click Save.
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 6. The list of outbound events contains the event just added. The 
Status column displays a value of OK if communication is working. 
If communication is not working, the Status column displays an 
error which you can use to repair communication.
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Configure the BMC Remedy Plugin for Integration with 
BeyondTrust Remote Support
Now that you have configured BMC Remedy and the B Series Appliance, deploy and configure the BMC Remedy plugin.

For more information on installing and working with the BeyondTrust Middleware Engine, please see the BeyondTrust Remote 
Support Middleware Engine Installation and Configuration document at www.beyondtrust.com/docs/remote-support/how-
to/integrations/middleware-engine.

 1. Copy the provided plugin ZIP file to the server hosting the BeyondTrust Middleware Engine.
 2. Extract the plugin ZIP file to the Plugins folder in the directory where the BeyondTrust Middleware Engine is installed.
 3. Restart the BeyondTrust Middleware Engine Windows service.
 4. From the server, launch the middleware administration tool. The default URL is http://127.0.0.1:53231.
 5. The BMC Remedy Plugin shows in the list of plugins. Click the clipboard icon to add a new configuration.

BeyondTrust Appliance B Series
The first portion of the plugin configuration provides the necessary settings for communication between the plugin and the B Series 
Appliance.  The configuration sections include:

 1. Plugin Configuration Name: Any desired value. Because multiple 
configurations can be created for a single plugin, allowing different 
environments to be targeted, provide a descriptive name to indicate 
how this plugin is to be used.

 2. Appliance Id: This can be left as Default or can be given a custom 
name. This value must match the value configured on the outbound 
event URL in the B Series Appliance. If outbound events are not 
being used, this value is still required, but any value may be used.

 3. BeyondTrust Appliance B Series Host Name: The hostname of 
the B Series Appliance. Do not include https:// or other URL 
elements.

 4. BeyondTrust Integration API OAuth Client ID: The client ID of 
the OAuth account.

 5. BeyondTrust Integration API OAuth Client Secret: The client 
secret of the OAuth account.

 6. Locale Used for BeyondTrust API Calls: This value directs the B 
Series Appliance to return session data in the specified language.

 7. Disabled: Enable or disable this plugin configuration.
 8. Allow Invalid Certificates: Leave unchecked unless there is a 

specific need to allow. If enabled, invalid SSL certificates are 
allowed in calls performed by the plugin. This would allow, for 
example, self-signed certificates. We do not recommend this in 
production environments.
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 9. Use Non-TLS Connections: Leave unchecked unless it is the specific goal to use non-secure connections to the B Series 
Appliance. If checked, TLS communication is disabled altogether. If non-TLS connections are allowed, HTTP access must be 
enabled on the BeyondTrust /login > Management > API Configuration page. We strongly discourage using non-secure 
connections.

 

Note: When using OAuth authentication, TLS cannot be disabled.

 10. Outbound Events Types: Specify which events the plugin processes when received by the middleware engine. Keep in mind 
that any event types selected here must also be configured to be sent in BeyondTrust. The Middleware Engine receives any 
events configured to be sent in BeyondTrust but passes them off to the plugin only if the corresponding event type is selected in 
this section.

 l Support Session End
 l Customer Exit Survey is Completed
 l Representative Survey is Completed

 11. Polling Event Types: If network constraints limit connectivity between the B Series Appliance and the middleware engine such 
that outbound events cannot be used, an alternative is to use polling. The middleware engine regularly polls the B Series 
Appliance for any sessions that have ended since the last session was processed. At this time, only the Support Session End 
event type is supported.

Note: One caveat to polling behavior versus the use of outbound events is that if a session has ended but the customer exit 
survey has not yet been submitted within the same polling interval, the customer exit survey is not processed. This does not 
apply to representative surveys since the session is not considered to be complete if a representative survey is still pending.

 12. Polling Interval: Enter only if polling is used. This determines how often the middleware engine polls the B Series Appliance for 
sessions that have ended.

 13. Retry Attempt Limit: Enter the number of retries that can be attempted if the plugin fails to process an event.
 14. Retry Outbound Event Types: Specify which outbound events the plugin retries if it fails to process an event.
 15. Retry Polling Event Types: Specify which polling events the plugin retries if it fails to process an event.

BMC Remedy Instance
The remainder of the plugin configuration provides the necessary settings for communication between the plugin and the BMC Remedy 
instance.  The configuration settings include:

 1. BMC Remedy Services URL: URL of the AR Service for the BMC Remedy instance (e.g., 
https://remedy.example.com/arsys/services/ARService).

 2. BMC Remedy Username: The username of the API account.
 3. BMC Remedy Password: The password of the above user.
 4. BMC Remedy AR Server: The name of the AR/app server instance.
 5. Session Reports Storage: Populate the session reports into the BeyondTrust Sessions tab, as a Work Note, or both.

The following settings apply only if Session Reports Storage is set to Work Notes or Both:

 l Work Info Source: The default value for the Source field on the Work Note (e.g., Email, Phone, Web, Other, etc.).
 l Work Info Type: The default value for the Type field on the Work Note. The name should contain no spaces or other non-

alpha characters (e.g., CustomerCommunication, GeneralInformation, IncidentTaskAction, etc.).
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 l Publish as Public Notes: Specifies whether to publish the notes as public or not.
 l Lock Log: Specifies whether to lock the work log or not.

After saving the configuration, click the test icon next to the new plugin configuration. No restart is needed.

Report Templates
On the BeyondTrust Middleware Engine server, in the <install dir>\Plugins\<integration>\Templates folder, there are multiple files 
ending with *.hbs. These are Handlebars template files. These files are used by the plugin to format the session report and exit surveys 
that are added to the corresponding ticket each time a BeyondTrust session ends or each time a survey is submitted. The templates can 
be edited if desired.

Note: If you are editing a template, we recommend copying and saving the original in case the changes need to be reverted.

For more information on Handlebars templates, please see the Handlebars website at handlebarsjs.com.
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Use Cases for the BMC Remedy Integration with BeyondTrust 
Remote Support

Generate Session Key
Support staff can generate a session key that can be given to the end user 
over the phone or via email to initiate a support session that is automatically 
associated with the selected ticket.

 

This can be done from within Smart IT.
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Import BeyondTrust Session Data into Ticket
Once the session ends, the ticket is automatically updated with information 
gathered during the session, including:

 l Chat Transcript (including files transferred, special actions, and 
other events)

 l System Information (the General section plus other select details 
such as disk, memory, and network)

 l Session Notes
 l Surveys (customer and representative)

To be flexible in meeting varying needs, session data can be displayed 
within a custom BeyondTrust Sessions tab on the Incident form, added as a 
Work Note, or both.
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Jump to Configuration Item
Support staff can leverage BeyondTrust Jump Technology to access a 
configuration item associated with a ticket directly from the BMC Remedy 
ticket.

 

Click-to-Chat for Self Service Users
Self Service users can open their submitted requests in the SRM Request 
Entry Console and start a chat support session directly from the BMC 
Remedy ticket. This allows the user the quickest path to resolution while 
also providing the representative with the necessary context to assist the 
user. Sessions can be elevated to full support sessions if enabled and when 
necessary.

 

Access Ticket from Representative Console
Using BeyondTrust's custom links ability, a representative can access the associated ticket directly from within the representative 
console.  This saves time searching for the ticket in BMC Remedy and provides the representative with any available \issue details, history, 
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or other context to help quickly resolve the issue.

Create Ticket via Smart IT
Using the Smart Recorder in Smart IT for BMC Remedy and BeyondTrust's custom links, a ticket can be created from within the 
representative console with a single click when the representative is in session. The customer name and issue description from the 
BeyondTrust session are automatically passed into the new ticket. If available, this can save time and unnecessary clicks for support staff.
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